Dependencies

Compiling Genet requires that following software to be installed:

Genet is also available in OPAM.

Git is required as it is used to identify versions of your project files. Graphviz must also be installed; it is used by the web interface to display clickable graphs. highlight is required to display colored diffs in web interface.

Compiling and installing

After extracting the source tree, go to the extracted directory and type:

./configureĀ [options]
make all
make install # with sufficient rights

The following files and repositories will be installed, using variables BINDIR, LIBDIR and SHAREDIR set during the configuration step: